BlackBerry Support Forum - Powered by vBulletin
Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 78
  1. #1
    BESadmin's Avatar
    BESadmin is online now Administrator
    Join Date
    Aug 2006
    Posts
    2,365
    Blog Entries
    109

    Desktop email program was unable to submit message.

    Q: After sending a message, an X appears beside the message. The Message Status is as follows: Desktop email program was unable to submit message.

    A: This occurs because the Desktop [CMIME] service book is corrupt or you have a "Send As" issue (details below).

    To correct the "Send As" issue I have outlined the steps below that I use to quickly resolve this error:

    1. Stop the Blackberry Router service.

    2. Open Active Directory and from the View menu select "Advanced Features". Then go to each user that will be added to the BES and open their properties, go to the security tab and add the user BESadmin and add the security permission "Send As".

    3. Run the following script logged on as Administrator
    Note: Only use this step if you have BlackBerry users that are members of Admin groups.

    dsacls "cn=adminsdholder,cn=system,dc=domainname,dc=c om " /G "DOMAINNAME\BESadmin:CA;Send As"

    Example 1: dsacls "cn=adminsdholder,cn=system,dc=experts-exchange,dc=com " /G "EXPERTS_EXCHANGE\BESadmin:CA;Send As"

    Example 2: dsacls "cn=adminsdholder,cn=system,dc=blackberryforum s,dc =com,dc=au " /G "BLACKBERRYFORUMS\BESadmin:CA;Send As"

    Example 3: dsacls "cn=adminsdholder,cn=system,dc=mobilenetwork,d c=lo cal" /G "MOBILENETWORK\BESadmin:CA;Send As"

    NOTE: dsacls can be found in the Windows Server 2003 SP1 Support Tools pack: Download details: Windows Server 2003 Service Pack 1 32-bit Support Tools

    4. Wait 20 minutes and then restart the BlackBerry Router service.

    5. Restart the BES server.


    Additional Information

    To globally apply Send As permissions to all user objects follow these steps:
    1. Open Active Directory.
    2. Select the "View" menu and ensure "Advanced Features" is checked.
    3. Right mouse click on your domain name and select Properties
    4. Select the Security tab
    5. Press the Advanced button at the bottom on the security tab
    6. Select "Add" and enter your Blackberry Service Account name (e.g. BESadmin) and select OK
    7. When the permissions screen appears change "Apply onto:" to "User Objects"
    8. In the permissions box scroll down and check the Allow box beside "Send As" and press OK
    9. Press Apply and OK to exit

  2. #2
    BESadmin's Avatar
    BESadmin is online now Administrator
    Join Date
    Aug 2006
    Posts
    2,365
    Blog Entries
    109

    UPDATE: 7th Feb 2007

    Desktop email program was unable to submit an email message

    Doc ID : KB04422
    Last Modified : 2007-06-08
    Document Type : Support

    Environment

    • BlackBerry® Desktop Software
    • BlackBerry smartphone
    • BlackBerry® Enterprise Server
    Problem

    After sending an email message from your BlackBerry smartphone, a red X appears beside the message in the messages list and the Message Status field displays the following error:

    Desktop email program was unable to submit message

    Note: The Message Status field appears above the To field within the message.

    Cause

    Summary of Causes

    This issue may be caused by the following:
    1. The BlackBerry Router on the BlackBerry Enterprise Server has stopped. This cause only applies to BlackBerry Enterprise Server software version 4.0 and later.
    2. Your mailbox is full.
    3. Send As Permissions
    Resolution

    Cause 1

    The BlackBerry Router on the BlackBerry Enterprise Server has stopped.

    Note: This cause only applies to BlackBerry Enterprise Server software version 4.0 and later.

    Resolution

    Restart the BlackBerry Router by completing the following steps:
    1. On the computer running the BlackBerry Enterprise Server, open the Control Panel.
    2. Go to Administrative Tools > Services.
    3. Right-click BlackBerry Router, then select Start.
    4. Close the Services window, then close the Control Panel.
    Cause 2

    Your mailbox is full.

    Resolution

    Make sure you have not reached, and are not close to reaching, your mailbox limit.

    Cause 3

    Send As Permissions

    Resolution

    Follow KB04707 to resolve the Send As Permissions issue.

    Additional Information

    This problem may also be caused by a revoked Send As permission. For more information, see KB04707.

  3. #3
    GaryCutri's Avatar
    GaryCutri is offline Moderator
    BlackBerry Device: z10
     
    Device Firmware: 10.1.0.264
     
    Email Configuration: BlackBerry 10 - Standard Data Plan
     
    Mobile Carrier & location: Telstra - Australia
     
    Join Date
    Sep 2006
    Location
    Melbourne
    Posts
    18,193
    Blog Entries
    68
    If you are connecting via a BlackBerry Enterprise Server please refer to the link below for more details:

    Unlisted message error or Desktop email program unable to submit message

  4. #4
    landale4 is offline Junior Member
    Join Date
    Sep 2008
    Posts
    1

    Talking Desktop email program was unable to submit message...

    I came across this issue and the user's Send As permissions were there and his mailbox was not full. I tried several times to delete and replace his desktop (cmime) service book with a new copy, but I couldn't get a replacement service book to show up on the device. Finally decided to check the eventlog on the BES and it had an error “User xxxxx@domain.com appears to be running on a BES administered with a separate database…..”
    As it turns out he had been added to two different servers. I had the BES admin remove him from the BES that I didn't have access to, then I reloaded the user account on the correct BES domain. This must have prompted activation, because within 10 minutes he had a message on his bb saying “Activation complete”. After that he was able to send/receive emails and everything worked as normal.

  5. #5
    GaryCutri's Avatar
    GaryCutri is offline Moderator
    BlackBerry Device: z10
     
    Device Firmware: 10.1.0.264
     
    Email Configuration: BlackBerry 10 - Standard Data Plan
     
    Mobile Carrier & location: Telstra - Australia
     
    Join Date
    Sep 2006
    Location
    Melbourne
    Posts
    18,193
    Blog Entries
    68
    Quote Originally Posted by landale4 View Post
    I came across this issue and the user's Send As permissions were there and his mailbox was not full. I tried several times to delete and replace his desktop (cmime) service book with a new copy, but I couldn't get a replacement service book to show up on the device. Finally decided to check the eventlog on the BES and it had an error “User xxxxx@domain.com appears to be running on a BES administered with a separate database…..”
    As it turns out he had been added to two different servers. I had the BES admin remove him from the BES that I didn't have access to, then I reloaded the user account on the correct BES domain. This must have prompted activation, because within 10 minutes he had a message on his bb saying “Activation complete”. After that he was able to send/receive emails and everything worked as normal.
    Thanks for the feedback.

  6. #6
    yunamx is offline Member
    BlackBerry Device: Bold 9000
     
    Device Firmware: 4.2.2.170
     
    Email Configuration: BlackBerry Enterprise Server (BES)
     
    Mobile Carrier & location: AT&T
     
    Join Date
    Jun 2009
    Posts
    5

    Desktop email program was unable to submit message

    Hi,

    i have this same problem, but only on two of the 15 blackberries we have. we are using bes 4.1 on exchange 2003. i tried the purge deleted items as suggested on other forms, the mailbox is not full, i've reset the bes service, i've tried turning off the blackberry for 2 hours, and no one is sending as admin. i am unable to stop the blackberry service for 2 hours, as other are still using it.

    i'm not sure what is wrong with the two blackberries. any help will be greatly appreciated. thanks in advance.

    p.s. where is the debug log? i've looked under c:\program files\research in motion, but it is not there. nor is it in the log folder.
    Last edited by yunamx; 16-06-2009 at 08:02 AM. Reason: added p.s. message

  7. #7
    GaryCutri's Avatar
    GaryCutri is offline Moderator
    BlackBerry Device: z10
     
    Device Firmware: 10.1.0.264
     
    Email Configuration: BlackBerry 10 - Standard Data Plan
     
    Mobile Carrier & location: Telstra - Australia
     
    Join Date
    Sep 2006
    Location
    Melbourne
    Posts
    18,193
    Blog Entries
    68
    Quote Originally Posted by yunamx View Post
    Hi,

    i have this same problem, but only on two of the 15 blackberries we have. we are using bes 4.1 on exchange 2003. i tried the purge deleted items as suggested on other forms, the mailbox is not full, i've reset the bes service, i've tried turning off the blackberry for 2 hours, and no one is sending as admin. i am unable to stop the blackberry service for 2 hours, as other are still using it.

    i'm not sure what is wrong with the two blackberries. any help will be greatly appreciated. thanks in advance.

    p.s. where is the debug log? i've looked under c:\program files\research in motion, but it is not there. nor is it in the log folder.
    To correct the "Send As" issue I have outlined the steps below that I use to quickly resolve this error:

    1. Stop the Blackberry Router service.

    2. Open Active Directory and from the View menu select "Advanced Features". Then go to each user that will be added to the BES and open their properties, go to the security tab and add the user BESadmin and add the security permission "Send As".

    3. Run the following script logged on as Administrator
    Note: Only use this step if you have BlackBerry users that are members of Admin groups.

    dsacls "cn=adminsdholder,cn=system,dc=domainname,dc=c om " /G "DOMAINNAME\BESadmin:CA;Send As"

    Example 1: dsacls "cn=adminsdholder,cn=system,dc=experts-exchange,dc=com " /G "EXPERTS_EXCHANGE\BESadmin:CA;Send As"

    Example 2: dsacls "cn=adminsdholder,cn=system,dc=blackberryforum s,dc =com,dc=au " /G "BLACKBERRYFORUMS\BESadmin:CA;Send As"

    Example 3: dsacls "cn=adminsdholder,cn=system,dc=mobilenetwork,d c=lo cal" /G "MOBILENETWORK\BESadmin:CA;Send As"

    NOTE: dsacls can be found in the Windows Server 2003 SP1 Support Tools pack: Download details: Windows Server 2003 Service Pack 1 32-bit Support Tools

    4. Wait 20 minutes and then restart the BlackBerry Router service.

    5. Restart the BES server.


    Additional Information

    To globally apply Send As permissions to all user objects follow these steps:
    1. Open Active Directory.
    2. Select the "View" menu and ensure "Advanced Features" is checked.
    3. Right mouse click on your domain name and select Properties
    4. Select the Security tab
    5. Press the Advanced button at the bottom on the security tab
    6. Select "Add" and enter your Blackberry Service Account name (e.g. BESadmin) and select OK
    7. When the permissions screen appears change "Apply onto:" to "User Objects"
    8. In the permissions box scroll down and check the Allow box beside "Send As" and press OK
    9. Press Apply and OK to exit

  8. #8
    yunamx is offline Member
    BlackBerry Device: Bold 9000
     
    Device Firmware: 4.2.2.170
     
    Email Configuration: BlackBerry Enterprise Server (BES)
     
    Mobile Carrier & location: AT&T
     
    Join Date
    Jun 2009
    Posts
    5

    fixed

    Hi Gary,

    that did the job. but do you know why it would only affect 2 of the 15 blackberries we have? it is strange that only the two would not send. it is not really that important, just curious. most important thing is that it works. thanks again for your help.

  9. #9
    GaryCutri's Avatar
    GaryCutri is offline Moderator
    BlackBerry Device: z10
     
    Device Firmware: 10.1.0.264
     
    Email Configuration: BlackBerry 10 - Standard Data Plan
     
    Mobile Carrier & location: Telstra - Australia
     
    Join Date
    Sep 2006
    Location
    Melbourne
    Posts
    18,193
    Blog Entries
    68
    Quote Originally Posted by yunamx View Post
    Hi Gary,

    that did the job. but do you know why it would only affect 2 of the 15 blackberries we have? it is strange that only the two would not send. it is not really that important, just curious. most important thing is that it works. thanks again for your help.
    If this issue was only affecting two users it is possible they are part of an Administration group. If you require further information have detailed the causes in the link below:

    Unlisted message error or Desktop email program unable to submit message

  10. #10
    yunamx is offline Member
    BlackBerry Device: Bold 9000
     
    Device Firmware: 4.2.2.170
     
    Email Configuration: BlackBerry Enterprise Server (BES)
     
    Mobile Carrier & location: AT&T
     
    Join Date
    Jun 2009
    Posts
    5

    New user with same issue

    there is now a new user is having the same issue. i had completed the guide you provided in the additional info - for all users. this user is not part of the admin group. the user says that he had this problem before and it resolved itself, but now it will not work. any ideas? thanks.

    p.s. i re-did the steps you provided for the single user and still did not work.
    Last edited by yunamx; 18-06-2009 at 03:09 AM. Reason: added p.s. message

Page 1 of 8 1 2 3 ... LastLast

Similar Threads

  1. Replies: 14
    Last Post: 13-08-2011, 03:12 AM
  2. Replies: 38
    Last Post: 30-09-2010, 02:49 AM
  3. Replies: 2
    Last Post: 07-07-2010, 06:25 AM
  4. Desktop Secure unable to submit message
    By rboepple in forum BlackBerry General Discussion
    Replies: 1
    Last Post: 04-12-2008, 10:33 PM
  5. Unable to view complete message from integrated email account
    By BESadmin in forum BlackBerry Web Client Support
    Replies: 0
    Last Post: 28-04-2007, 11:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search Engine Friendly URLs by vBSEO 3.6.1